Failed to resolve: com.android.support.constraint:constraint-layout:1.0.0-alpha9

来源: Failed to resolve: com.android.support.constraint:constraint-layout:1.0.0-alpha9 <a – CSDN博客

把一个工程导入as 的时候报错,Failed to resolve: com.Android.support.constraint:constraint-layout:1.0.0-alpha9,

很明显是constraint-layout的依赖的问题。

怎么解决这个问题呢,其实也不难,主要是你的Android studio里没有constraint-layout:1.0.0-alpha9这个东西。怎样确定你的Android studio里有哪个版本呢?

第一步,先点击1处的SDK Manager,然后就会有个弹出一个比较大的对话框

第二步,点击SDK tools。

第三步,勾选右下角的show Package Details

第四步,你就可以看到你安装了constraint-layout的哪个版本了,如果一个也没有装,那就赶紧勾选一个,然后点击ok,Android studio就会开始下载了。

刚刚我们说到你的Android studio里没有constraint-layout:1.0.0-alpha9这个东西,所以报错,那么解决这个bug的方法就是,安装constraint-layout:1.0.0-alpha9这个版本就好了。

当然比如说你的Android studio里装的是constraint-layout:1.0.0而不是constraint-layout:1.0.0-alpha9,那么你也可以把app的build.gradle里constraint-layout:1.0.0-alpha9改成constraint-layout:1.0.0。这样Sync按钮后也可以解决这个问题。

如果本文对你有帮助的话,麻烦在下方点个赞,谢谢支持。

分享到: 更多 (0)