This version of android studio is incompatible with the gradle version used. – 张武不是技术宅的博客 – CSDN博客

来源: This version of android studio is incompatible with the gradle version used. – 张武不是技术宅的博客 – CSDN博客

问题背景

因为项目app分包需要,将工程的graddle版本升至了2.2.0 alpha4,而我的Android studio 一向升级为最新版,于是就出现了题目中的报错:

Error running app: This version of Android Studio is incompatible with the Gradle Plugin used. Try disabling Instant Run (or updating either the IDE or the Gradle plugin to the latest version)

当前版本的Android studio 与 gradle不兼容。在log中 提示我升级ide和gradle为最新版,然而我出问题的就是最新版,于是尝试 禁用Instant Run,但仍然不能解决问题。

解决方案

通过百度log中的问题,在stackoverflow上有人提出了解决方案。

参考:http://stackoverflow.com/questions/35202541/this-version-of-android-studio-is-incompatible-with-the-gradle-version-used-try

step1:

禁用Instant Run,在Settings/Preferneces > Build, Execution, Deployment option > Instant Run 中,取消所有的选中项

 

step2:

更新gradle services 的url:在project目录下的 gradle>wrapper>gradle-wrapper.properties中将

distributionUrl=https://services.gradle.org/distributions/gradle-2.10-all.zip

更新为:

distributionUrl=https://services.gradle.org/distributions/gradle-2.11-all.zip

step3:

删除project下的build文件夹

step4:

clean项目,重新编译跑程序

分享到: 更多 (0)