lnmp 安装laravel框架 – ZzyYeMen – 博客频道 – CSDN.NET

环境要求:      操作系统:centOS;    PHP 5.4.4 (>=5.4即可)首先装好composer curl -sS https://getcomposer.org/installer | php mv composer.phar /usr/local/bin/composer安装完成,使用以下命令看是否安装成功composer -V安

来源: lnmp 安装laravel框架 – ZzyYeMen – 博客频道 – CSDN.NET

环境要求:

操作系统:centOS;

PHP 5.4.4 (>=5.4即可)

首先装好composer

  1. curl -sS https://getcomposer.org/installer | php
  2. bsp;mv composer.phar /usr/local/bin/composer

安装完成,使用以下命令看是否安装成功

  1. composer -V

安装Laravel依赖于一些的php扩展

  1. yum install  php-mySQL php-mcrypt php-mbstring php-tokenizer php-openssl

安装完成后,在Nginx的配置文件配置

  1. location / {
  2.                try_files $uri $uri/ /index.php?$query_string;
  3.     }

配置好后咱们就开始安装laravel

  1. composer create-project laravel/laravel –prefer-dist my_laravel

大约8分钟时间,差不多就安装好了,最后来到你的laravel工程目录下,看到storage和vendor文件夹,使用以下命令修改其文件读写权限,让Nginx用户能读写它

  1. sudo chmod -R 766 storage sudo chmod -R 766 vendor

 

分享到: 更多 (0)