System.Runtime.InteropServices.RuntimeInformation.dll 问题 mongoDB C# 驱动 问题_m0_37867491的博客-CSDN博客

baacloud免费翻墙vpn注册使用

来源: System.Runtime.InteropServices.RuntimeInformation.dll 问题 mongoDB C# 驱动 问题_m0_37867491的博客-CSDN博客

基于上一篇博客的mongoDB 和mongoDB C# 驱动 教程之后,小白将这个问题单独列出来,可见小白对这个问题已经达到了深恶痛绝的程度。。。。

总结: 在基于mongoDB 3.x 与 mongoDB C#  CSharpDriver 2.x 的配合使用中遇到问题总结。

(1) 版本问题: 找到相匹配的版本很重要,有好多版本两者是不支持的。小白建议:一定要查看官网,不可轻信网上博客主。

版本匹配地址:https://docs.mongodb.com/ecosystem/drivers/csharp/点击打开链接

重要的事情说三遍。。。。    重要的事情说三遍。。。。    重要的事情说三遍。。。。

(2)提示缺少 xx.dll 。 在基于vs2012 开发过程中,小白就遇到问题,网上建议去更新NuGet 包,如果还是不行,小白建议去网上下载相应的dll。

eg个栗子:缺少 System.Runtime.InteropServices.RuntimeInformation.dll version = 4.0.0 这个错。网上的回答很少,小白就是下载了System.Runtime.InteropServices.RuntimeInformation.dll 而解决的。

受前辈指点,可能是缺少 VC++ 20XX 的库,特此补充。

下载地址:

链接:https://pan.baidu.com/s/1jh9JKVKBzkXD_E7EAHUdMQ 密码:wxg6

如果提示版本不对,那就去网上下载。

(3).net 框架不对。这个也参考官网 https://docs.mongodb.com/ecosystem/drivers/csharp/点击打开链接

(4)我遇到的问题是因为其他库需要RuntimeInform的版本冲突,于是在NuGet包管理器中更新了需要升级的包编译后就不出问题了

赞(0) 打赏
分享到: 更多 (0)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏