flutter version solving failed. - 简书

baacloud免费翻墙vpn注册使用

来源: flutter version solving failed. – 简书

记录一次运行flutter时碰到的问题已经解决办法,希望对碰到类似问题的伙伴有所帮助。

1. 使用flutter run运行flutter的hello_world的example遇到了依赖版本解析问题(Because hello_world depends on flutter_test any from sdk which depends on test_api 0.2.1, test_api 0.2.1 is required.So, because hello_world depends on test_api 0.2.2, version solving failed.),具体如下错误如下图,报错内容只说了依赖有问题,但是没有提供解决方案,只能自行查找。

2. 遂google一下,在flutter的github issue发现有人建议使用flutter doctor -v检查一下flutter的安装是否有问题,在跑flutter doctor -v之后没有发现影响的问题。

3. 继续看,发现使用flutter run -v可以打印运行时的log,有了清晰的log,问题的解决方案就显现了出来。

4. 按照提示执行flutter packages get安装完成后再次运行flutter run可以正常运行。

5. 虽然程序run起来了,但是由于adb版本问题,hot reload功能无法正常使用,(adb did not report forwarded port)。这个通过升级adb即可解决,flutter github的issue也有提到。

小结:

flutter尽管已经发布了1.0版(我使用的是1.1.8)但是有些细节方面的工作还是有点欠缺,需要使用者更熟悉flutter才更好的驾驭。刚运行flutter就遇到不能google快速解决问题确实还是有些挫折的,社区还需要大家一起多多贡献慢慢成熟。

遇到问题:

1.flutter doctor -v

2. 在运行的命令后加-v,输出log定位问题(比如 flutter run -v)

作者:emmonsthehound
链接:https://www.jianshu.com/p/3059c7c13355
来源:简书
著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。

赞(0) 打赏
分享到: 更多 (0)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏