ThinkPHP5.1 安装 workerman 指导 - 云+社区 - 腾讯云

baacloud免费翻墙vpn注册使用

来源: ThinkPHP5.1 安装 workerman 指导 – 云+社区 – 腾讯云

★ 背景

  • 最近需要在自己的网站后台,设计消息推送业务,通过网上资料参考,觉得 workerman 是个很好的选择,在此记录一下ThinkPHP5.1 框架下的安装操作,希望可以帮到更多的人 …

workerman 手册

  • 环境
框架版本:ThinkPHP5.1.2
使用工具:composer
系统环境:Win10、CentOS7.2

☆ 指导步骤

首先,因为配置条件多有不同,需要根据自己的情况稍作调整的哦 (仅作为友情提示…)

①. 进入项目根目录,运行 composer 命令

  • 安装命令如下:
composer require topthink/think-worker
  • 此时,会有提示信息:
Using version ^3.0 for topthink/think-worker
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - topthink/think-worker v3.0.3 requires topthink/framework ^6.0.0 -> satisfiable by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3, v6.0.0-rc4] but these conflict with your requirements or minimum-stability.
    - topthink/think-worker v3.0.2 requires topthink/framework ^6.0.0 -> satisfiable by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3, v6.0.0-rc4] but these conflict with your requirements or minimum-stability.
    - topthink/think-worker v3.0.1 requires topthink/framework ^6.0.0 -> satisfiable by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3, v6.0.0-rc4] but these conflict with your requirements or minimum-stability.
    - topthink/think-worker v3.0.0 requires topthink/framework ^6.0.0 -> satisfiable by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3, v6.0.0-rc4] but these conflict with your requirements or minimum-stability.
    - Installation request for topthink/think-worker ^3.0 -> satisfiable by topthink/think-worker[v3.0.0, v3.0.1, v3.0.2, v3.0.3].


Installation failed, reverting ./composer.json to its original content.
  • 解释: 这是因为,在不填写所需扩展的版本号前提下,会默认下载最新版本 但是,当前的框架版本很可能不支持,比如,此时要求必须要是 ThinkPHP6.0 框架 而鄙人的版本是 ThinkPHP5.1.2
  • 解决方案:就是,直接指定所需要的扩展包版本

当然,如果你的 ThinkPHP 版本足够高,此时应该会直接顺利的安装,后面的就无需多看咯

②. 获取可选择的 workerman 版本

为了指定安装的版本,所以我们要知道,有哪些可选择的版本

  • composer.json 文件中的 "require" 数组中,先补充一条数据:"topthink/think-worker":"0.1"
  • 此时,命令行执行:composer update
  • 根据自己的 ThinkPHP 版本选择合适的扩展
> 以我为例,试着选择了 "v3.0.0" (依然版本要求太高)、 "v2.0.9" (当前较合适)
> 然后进行安装操作
> 此时可以有两种方式,个人建议选用后者
> 
> 第一种方式:
> 直接修改前面所提及的 "composer.json" 文件中的版本号:"topthink/think-worker":"v2.0.9"> 然后,再次执行一遍命令:composer update
> 
> 第二种方式:
> 删掉前面 "composer.json" 文件中 补充测试的内容:"topthink/think-worker":"0.1"
> 然后,执行命令:composer require topthink/think-worker=v2.0.9
  • 执行的打印信息,如下:
  • 【安装完成】 安装成功后,你可以发现会多出 "/vendor/topthink/think-worker""/vendor/workerman" 目录 并且,在目录 "/config" 中,会自动生成 workerman 对应的三个配置文件

附录

参考文章

  • Linux 系统检测 Linux系统可以使用以下脚本测试本机 PHP 环境是否满足 WorkerMan 运行要求
curl -Ss http://www.workerman.net/check.php | php

上面脚本如果全部显示ok,则代表满足 WorkerMan 要求

赞(0) 打赏
分享到: 更多 (0)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏