【Gradle】Gradle报错:Using insecure protocols with repositories,without explicit opt-in,,is unsupported._alone_yue的博客-CSDN博客

baacloud免费翻墙vpn注册使用

来源: 【Gradle】Gradle报错:Using insecure protocols with repositories,without explicit opt-in,,is unsupported._alone_yue的博客-CSDN博客

1.问题描述
将gradle.build仓库更换为阿里云仓库后报错

 

2.解决方案
第一种:在仓库前添加关键字:
allowInsecureProtocol = true

plugins {
id ‘org.springframework.boot’ version ‘2.5.2’
id ‘io.spring.dependency-management’ version ‘1.0.11.RELEASE’
id ‘java’
}

group = ‘com.example’
version = ‘1.0.0’
sourceCompatibility = ‘1.8’

repositories {
// mavenCentral()
maven{
allowInsecureProtocol = true
url ‘http://maven.aliyun.com/nexus/content/groups/public/’}
}

dependencies {
implementation ‘org.springframework.boot:spring-boot-starter-web’
testImplementation ‘org.springframework.boot:spring-boot-starter-test’

implementation ‘org.apache.logging.log4j:log4j-core:2.14.1’
}

test {
useJUnitPlatform()
}

第二种将阿里云的连接http换成https

在这里插入图片描述

————————————————
版权声明:本文为CSDN博主「alone_yue」的原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/qq_46514118/article/details/121746827

赞(0) 打赏
分享到: 更多 (0)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏