Flutter Error: Cannot run with sound null safety, because the following dependencies don‘t support_吴庆森的博客-CSDN博客

baacloud免费翻墙vpn注册使用

来源: Flutter Error: Cannot run with sound null safety, because the following dependencies don‘t support_吴庆森的博客-CSDN博客

版本运行的时候可以有下面的报错:

说明包不安全,第一种简单方法是,打开终端进入项目所在的文件夹,输入命令:

flutter run –no-sound-null-safety
这样需要每次都用命令打包,另一种方法,找到 main.dart ,然后右键点击,找到 Edit ‘main.dart’… 如下图所示:

找到第二行 flutter additional run args ,添加:–no-sound-null-safety,点击 OK 即可,如下图:

这样再运行就不会报错了。
————————————————
版权声明:本文为CSDN博主「吴庆森」的原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/wuqingsen1/article/details/121030584

赞(0) 打赏
分享到: 更多 (0)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏